Sie sind nicht angemeldet.

1

Montag, 30. Januar 2017, 15:56

Zum Start muss immer der embedded controller resetet werden

Hallo!
Bei meinem Notebook (Acer E5-573) ist folgendes Problem:

Fährt man das Notebook herunter und ist der Akku eingesteckt, so startet das Notebook erst, wenn der embedded controller resetet wird (durch das kleine Loch am Bodenn des Notebooks mit Büroklammer). Ist der Akku nicht eingesteckt und wird das NB nur mit Netzteil betrieben, so tritt dieses Problem nicht auf. Der Akku wird im Betrieb normal geladen und funktioniert.
Kann dies am Akku liegen bzw lohnt es, einen neuen Akku zu kaufen?

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

2

Montag, 30. Januar 2017, 16:44

Hallo Buddy,

leider ist bei Deinem Modell der Akku übel teuer und intern verbaut. Wäre das nicht der Fall, dann würde ich durchaus dazu raten "auf gut Glück" mal einen anderen Akku zu probieren, bevor man sich eine stundenlange Fehlersuche antut.
Notebook-Akkus können nämlich wirklich gemeine Fehler verursachen. Ihre interne Elektronik beinhaltet allen Ernstes einen Mikrocontroller, der mit dem Mainboard, bzw. dem EC kommuniziert ...

Gut, in Deinem Fall kauft man nicht mal eben aus Faulheitsgründen einen neuen Akku. Jedenfalls nicht als erste Tat.
Ich würde zunächst mal versuchen, das BIOS neu zu flashen.
Überprüfe spaßeshalber auch mal die Spannung der Knopfzelle.

Erst nach diesen beiden Aktionen würde ich einen neuen Akku versuchen.
Wenn das nicht helfen sollte, KÖNNTE der EC 'ne Macke haben. Den auszutauschen ist aber ein echter Akt ...
Zudem bin ich nicht restlos davon überzeugt, dass danach alles gut wäre, denn der EC speichert intern ein paar Byte und ich muss zugeben, nicht genau zu wissen, wie die da hinein kommen ...
Defekte Embeded Controler sind nicht gerade alltäglich.

Andere (Hardware-) Fehler halte ich für eher unwahrscheinlich, da es ja nach einem Reset funktioniert, wie Du schreibst.

Wenn das Flashen des BIOS nichts bringen sollte und auch die Spannung der Knopfzelle OK ist, dann hast Du wohl leider ein richtig übles Problem am Hals (ein Fall, um den ich mich nicht prügeln würde, den zur Repa anzunehmen!).
Es tut weh, dann aus Verzweiflung einen neuen Akku zu kaufen, ohne dass man die Erfolgsaussicht überhaupt abschätzen könnte.

Sorry, aber klügeren Rat kann ich hier leider beim besten Willen nicht geben. :-S
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

3

Montag, 30. Januar 2017, 21:36

Danke für die schnelle und ausführliche Antwort!

Sieht leider so aus als ob ich wirklich das Pech habe, einen defekten EC zu haben, denn außer neuem Akku hab ich alles ohne Erfolg durchprobiert.

4

Montag, 30. Januar 2017, 23:02

Vielleicht ist ja die Reset Schaltung des EC defekt.

Den Schaltplan gibt es übrigens hier:

Versteckter Text Versteckter Text

Dieser Text wurde vom Autor versteckt.


Hat das Notebook ein Loch mit Reset Taster auf der Unterseite? Sowas hab ich noch nie gesehen.

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

5

Dienstag, 31. Januar 2017, 01:51

Danke für den interessanten Link, battery!
Die Seite kannte ich noch gar nicht.

Allerdings ist die Seite mit Vorsicht zu genießen, siehe hier:
https://www.google.com/transparencyrepor…l=laptopblue.vn

Scripte sollte man da wohl besser blockieren. Aber ohne Scripte funktioniert die Suchfunktion nicht ... :-(

Und - ich will zwar kein Spielverderber sein, aaaber ... ich habe Deinen Link mal lieber auf "versteckt" geschaltet, so dass ihn nur von mir handselektierte User mit entsprechenden Rechten sehen können (so für rein wissenschaftliche Zwecke, versteht sich!). Ich befürchte nämlich, dass man sich auf dieser Seite um das Thema "Copyright" weniger schert, als manche komplett weltfremde Richter vom Hamburger Landgericht ... :-(


Ein Reset-Loch im Boden war mir bislang übrigens ebenfalls unbekannt. Aber wenn Buddy meint, er hätte damit Erfolg gehabt ...
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

6

Dienstag, 31. Januar 2017, 07:25

Nochmal Danke für die Antworten und den Link zu den Schaltplänen. Leider bin ich nicht Fachkundig genug, um diese richtig zu verstehen bzw. Reperaturmöglichkeiten daraus ableiten zu können. Löten müsste ich eh den Leuten überlassen, die es richtig können ;-).

Ja, zu diesem Loch an der Unterseite sagt die Anleitung folgendes: "Loch für die Zurücksetzung des Computers - Entspricht dem Herausnehmen und Wiedereinsetzen des Akkus. Stecken Sie eine Büroklammer in die Öffnung und drücken Sie vier Sekunden lang."
Wie gesagt wenn ich dies tue und noch denPower Knopf ein paar Sekunden gedrückt halte, geht es. Dies ist aber nur erforderlich, wenn der Netzstecker gezogen wurde.

Aber sei es drum, war ein Austauschboard, welches ich günstig in der Bucht ergattert hatte (wie ich dachte). Das alte Board hatte den typisch hier beschriebenen "macht keinen Mucks mehr" Fehler. Leider bin ich zu spät auf diese Seite gestoßen aber vielleicht ist da noch was zu retten.

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

7

Dienstag, 31. Januar 2017, 13:24

@Buddy: Ein Mainboard, das absolut keinen Mucks mehr von sich gibt, ist in mindestens 95% aller Fälle reparabel.
So was mache ich bekanntlich zum Pauschalpreis von 100,- EUR brutto.

Da Dein Ersatz-Mainboard aus der Bucht aber funktioniert (mal von der Reset-Macke abgesehen), ist es vielleicht ratsam, wenn Du einfach damit lebst, so wie es ist.
Sooo schlimm ist es ja nicht, vor dem Einschalten für vier Sekunden mit 'ner Büroklammer durch besagtes Loch auf der Unterseite zu stochern.


Wenn Du es gerne komfortabler haben möchtest, mein Tipp für den pragmatisch gestrickten Sparer:
Biege eine Büroklammer so zurecht, dass Du sie mit Klebeband flach unter das Gerät kleben kannst, jedoch ein scharf abgewinkeltes Endstück gerade tief genug in das Löchle eintaucht, um den Reset zu ermöglichen.

So, wie ich mir das vorstelle, würde der Reset nicht von allein ausgelöst werden, weil das Gerät ja auf Fußpads steht und die Büroklammer so gerade eben den Tisch nicht berührt. Das Drahtende taucht also nicht von selbst voll ins Loch ein, sondern nur kleines ein Stück.
Bei Bedarf muss dann das Gerät nur kurz nach hinten gekippt werden, so dass man mit der Hand drunter langen kann. Beim Druck auf den etwas federnden Draht, würde der Endwinkel dann weit genug eintauchen.
(Macht in dieser Form natürlich nur dann Sinn, wenn man hinten keine Schnittstellen belegt hat, die beim Kippen nach hinten stören würden).
Somit hättest Du einen primitiven (aber komfortabler als bisher) von Hand bedienbaren "Taster" realisiert.

Alternativ (und hübscher): Den Pieckser einer Reißzwecke sorgsam kürzen und um das Löchle etwas Latex-Schwabbel, oder Schaumstoff montieren (zwecks Rückfederung). Dann die Reißzwecke unter einem runden Aufkleber unter das Gerät kleben.
Das sieht dann auch von unten betrachtet nicht mehr nach üblem Pfusch aus und man kann die Stelle gut mit der Hand ertasten.
Bei Fingerdruck taucht der gekürzte Piekser dann gerade tief genug ein, um den Reset auszulösen. Anschließend federt die Zwecke von selbst zurück, wegen dem Latex, bzw. Schaumstoff-Fitzelchen.

Abwandlungen jedweder Art überlasse ich mal Deinem Einfallsreichtum.

Wichtig ist halt in jedem Fall, dass die Gerätefüße hoch genug sind, so dass der Reset wirklich nicht schon vom bloßen Herumstehen des Gerätes ausgelöst wird. - Auch nicht beim Tippern auf der Tastatur (manche Geräte sind recht wabbelig konstruiert und biegen durch!)

Jedenfalls hättest Du auf diese Weise zum Nulltarif, mit einer simplen Bastelei, einen Zustand herbeigeführt, der schon mal eine deutliche Erleichterung darstellt, so dass die Macke kaum noch ins Gewicht fällt.

(Ich weiß, ich bin ein miserabler Geschäftsmann, dass ich solche Tipps absondere!)
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

8

Dienstag, 31. Januar 2017, 19:56

WOW! Danke für den praktischen Tip! Ideen muss man haben.

Irgendwie reizt es mich aber zu wissen, was mit dem Board, welches keinen Mucks mehr macht, los ist, so dass ich denke ich würde es Dir mal zum reparieren zukommen lassen. Was das angeht, bin ich wohl auch ein schlechter Geschäftsmann aber so hebt es sich vielleicht auf und das basteln macht Freude :-)

9

Dienstag, 31. Januar 2017, 23:29

Danke für den interessanten Link, battery!
Allerdings ist die Seite mit Vorsicht zu genießen, siehe hier:
https://www.google.com/transparencyrepor…l=laptopblue.vn


Ja ich habe dank einem anderen Thread in diesem Forum seit einiger Zeit NoScript installiert und daher konnte mir recht wenig auf der Seite passieren ;-) Macht mir übrigens nix wenn du den Link versteckst. Hauptsache buddy hat ihn;-)

@buddy
Ich hab derzeit noch ein Dell Notebook, das ab und zu einen CMOS Reset verlangte. Anderfalls startete es nicht. Zu allem Überfluss musste man das Gerät komplett zerlegen um an die CMOS Batterie zu kommen. Jetzt hab ich mal das CD Laufwerk und ein (von 2) RAM Riegel ausgebaut. Inzwischen ist das ein paar Wochen her und seither startete es immer ohne Probleme. Ich vermute, dass diese neuen Geräte (tendenziell solche mit UEFI) softwareseitig den Start verhindern sobald irgendwas nicht ganz stimmt. Wenn es bei dir auch sowas einfaches ist wär gut. Dein Notebook hat auch 2 RAM Riegel. Kannst ja mal abwechselnd jeweils einen testen. Um an den RAM zu kommen musst du die Unterschale abschrauben und hast dann das Mainboard direkt vor dir wenn ich das richtig gesehen habe.
Ob es bei meinem Notebook nun der RAM oder das Laufwerk war, kann ich momentan nicht sagen. Vllt baue ich in ein paar Monaten die Teile wieder ein. Wenn dann gleich wieder ein CMOS Reset nötig ist wäre die Sache klar. Aber solange es läuft muss man eben immer auch bedenken: "Never change a running System". D.h. wenn dir der Ein oder Andere Eingriff zu heikel ist, dann lieber nicht löten oder einen Fachmann ran lassen.

10

Mittwoch, 1. Februar 2017, 07:50

Hallo battery,

Danke für den Tip! Das mit dem Ram werde ich mal probieren. CD-Laufwerk schließe ich aus, da ich das schon draußen hatte und das Problem bestand weiterhin.
Und keine Sorge: Notebook zerlegen klappt, nur bei Lötarbeiten komme ich an meine Grenzen und würde das lieber Leuten überlassen, die es richtig können :-)

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

11

Mittwoch, 1. Februar 2017, 13:34

Ja ich habe dank einem anderen Thread in diesem Forum seit einiger Zeit NoScript installiert und daher konnte mir recht wenig auf der Seite passieren ;-)
Ja NoScript ist super! Es gehört sofort nach einer Firefox-Installation diesem hinzugefügt.
Allerdings frage ich mich, wie Du mit aktivem NoScript den besagten Link gefunden hast? Die Suchfunktion der Seite funzt dann nämlich nicht, wie ja schon von mir erwähnt.
Hast Du den Link etwa über eine externe Suchmaschine gefunden?

Wenn man sonderbare Webseiten immer munter freischaltet, sobald etwas nichts funzt, weil NoScript blockiert, dann kann man sich NoScript auch schenken. Das wäre ja so, wie einen Anschnallgurt zwar zu haben, ihn im Auto aber nicht anzulegen, weil er stört ...


Macht mir übrigens nix wenn du den Link versteckst. Hauptsache buddy hat ihn;-)
Ich habe ihm natürlich unverzüglich die nötigen Rechte verpasst. :-)


Jetzt hab ich mal das CD Laufwerk und ein (von 2) RAM Riegel ausgebaut. Inzwischen ist das ein paar Wochen her und seither startete es immer ohne Probleme.
Selbstflüsternd baut man alles ab, was geht, wenn man ein Mainboard testet. Das CD-Laufwerk sowieso.
Nur den Prozessor und das RAM lasse ich normalerweise zunächst mal drin. Im Laufe der Fehlersuche kann es aber sein, dass ich auch mal das RAM kurz entnehme.
Prozessoren gehen (so sonderbar es klingt) im Notebook in sehr guter Näherung nie kaputt. Und RAM-Riegel nur seeehr sehr sehr selten.
Bei Desktop-PCs soll es anders sein, aber das ist nicht mein Gebiet; so was leite ich gleich an meinen Kollegen Jan Lender weiter.

Übrigens passt Dein Rat (obwohl allgemein sinnvoll) IMHO nicht zu Buddys beschriebenem Schaden ("macht keinen Mucks mehr").
Theoretisch könnte natürlich ein Kurzschluss auf einem RAM-Riegel alles lahm legen, aber Du sprichst von Software/UEFI. Wenn aber bloß das UEFI irgend watt blockieren würde, dann wäre das MB nicht komplett ohne "Mucks", sondern dann würde durchaus noch 'ne LED kommen, oder (wenn auch nicht mit absoluter Sicherheit) der Lüfter kurz anlaufen, sobald man Spannung anlegt.

Wenn ein Mainboard wirklich absolut gar nichts tut, nicht auch nur das winzigste Lebenszeichen, dann wird der Fehler im Bereich der Stromversorgung liegen.
Vorausgesetzt, das externe Netzteil ist OK, sind das hier typischen Ursachen schlechthin:

  1. Stromeingangsbuchse defekt
  2. Kurzschluss zwischen den Platinenlagen (meistens direkt beim Plus-Anschluss der Buchse)
  3. Kondensator mit internem Kurzschluss
  4. Defekter MOSFET
  5. Defekter Schaltregler.

Alle anderen Fehler, die sonst irgendwie ein "komplett tot" bewirken könnten, sind so verschwindend selten, dass man da eigentlich gar nicht drüber nachzudenken braucht.

Anders sieht es natürlich aus, wenn das MB nicht wirklich komplett tot ist, sondern noch winzigste Regungen zeigt. Gelegentlich aufblitzende LED, oder so ...
- In solchen Fällen gibt es deutlich mehr, als die oben aufgezählten Ursachen. Und dann geht es leider oft richtig ins Eingemachte!
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

12

Mittwoch, 1. Februar 2017, 15:06


Hast Du den Link etwa über eine externe Suchmaschine gefunden?

Anders sieht es natürlich aus, wenn das MB nicht wirklich komplett tot ist, sondern noch winzigste Regungen zeigt. Gelegentlich aufblitzende LED, oder so ...


Ja hab den Schaltpan direkt über Google gefunden. Einer der ersten Treffer.

Bei mir war es tatsächlich so, dass das Gerät nicht startete aber eine einzelne LED langsam, dauerhaft blinkte. Aber kein Lüfter. Aber ob die LED blinkt oder ganz aus bleibt, oder überhaupt noch vorhanden ist hängt ja vom Hersteller ab. Man kann Dell nicht direkt mit Acer vergleichen. Allerdings geb ich dir Recht, wenn LEDs an buddys Notebook da sind könnte man die im Fehlerfall auch mal kurz aufleuchten lassen sofern es ein "Software-Abschalten" ist.

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

13

Mittwoch, 1. Februar 2017, 16:14

Die LEDs waren ja nur ein Beispiel.
Gemeint war: Wenn sich noch eine LED regt, dann ist das MB eben nicht vollkommen tot!
Oder wenn sich sonst was regt, ist das MB ebenfalls nicht komplett tot.

Mindestens die Power-LED sollte ja wohl kommen, wenn man das Netzteil anstöpselt. Bei NT + Akku auch die Lade-LED.
Wenn nicht, dann halt tot. Ungeachtet von Fiesimatenten seitens UEFI/BIOS.
Geräte ganz ohne LEDs fallen mir gerade nicht ein. Gibt es die?

Aber die LEDs sind ja sowieso nur so ein allererster Grobindikator.
Wenn ich sehe, dass nix leuchtet und sich auch sonst nichts regt, dann greife ich ganz routinemäßig unmittelbar zu Oszi, oder Multimeter und messe mal die Spannung hinter dem zweiten Eingangs-MOSFET.
Wenn da 19V anliegen, dann suche ich die 5V/3,3V-Regler und schaue, ob die schwingen.

Weiterhin überwache ich die ganze Zeit den Eingangsstrom, mit meinem bewährten Netzteil-Tester, den ich zwischen NT und MB schalte.
Ein komplett totes MB zieht entweder nicht den kleinsten Eingangsstrom, oder es hat einen satten Kurzschluss und zwingt dadurch das NT in die Knie.
Würde auch nur eine einzige LED leuchten, oder ein Schaltregler zumindest im Leerlauf werkeln, so würde ich das schon am Eingangsstrom sofort bemerken, ohne überhaupt eine Messspitze angesetzt zu haben. Und das heißt dann eben nicht "komplett tot". Dann kann man sich gerne über UEFI und viele weitere Dinge den Kopf zerbrechen, aber halt nicht als erste Tat.
Wenn Buddy schreibt, sein MB würde "keinen Mucks" machen, dann würde ich ganz sicher nicht zuerst an UEFI-Probleme denken!

So eine Grundregel, bei Elektronik-Problemen:
Zuerst immer erst die Stromversorgung kontrollieren!
Dabei auch an fiese Probleme denken, wie kurze Spikes, die ein 08/15-Multimeter gar nicht erfassen kann.
Mit dem Oszi ist man da besser bedient. Und für unsere Fälle ausreichend leistungsstarke Oszis bekommt man ja heute schon für Preise, die man noch vor wenigen Jahren für ein durchschnittliches Multimeter bezahlt hat (kaum mehr, als 'n Hunni teilweise sogar weniger als 'n Fuffi!).

Eine Elektronik kann noch so irre Sachen machen - wenn die Stromversorgung nicht OK ist und man das nicht bemerkt, dann jagt man Phantomen hinterher, denn eine Elektronik kann gar nicht anders, als zu zicken, wenn sie unterversorgt/fehlversorgt ist.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

14

Mittwoch, 1. Februar 2017, 17:06

Ok jetzt weiß ich was du meintest. Ein Notebook ohne LEDs hatte ich noch nicht, aber dafür ein Lenovo Egde. Das hat eine LED, die leuchtet wenn das Netzteil angesteckt ist (aber ohne dass die 3,3v und 5V regler laufen!!) und dann nur noch eine LED in dem Thinkpad Schriftzug als I-Punkt.

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

15

Mittwoch, 1. Februar 2017, 17:45

Das hat eine LED, die leuchtet wenn das Netzteil angesteckt ist (aber ohne dass die 3,3v und 5V regler laufen!!)
Das kenne ich nur von direkt in die Stromeingangsbuchse integrierten LEDs.
Oder befindet sich beim Lenovo Edge allen Ernstes eine LED auf dem Mainboard, die direkt aus der Eingangsspannung versorgt wird?
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

16

Mittwoch, 1. Februar 2017, 19:18

Der Ram war es leider auch nicht...Problem besteht weiterhin. Versuche gerade mal ein älteres Bios zu flashen, da dort in der Beschreibung stand "update EC"...vielleicht hilft es was. Allerdings ist es gar nicht so einfach ein älteres Bios zu flashen.

Zu dem "alten Board ohne Mucks": Es macht wirklich keinen Mucks und nix leuchtet. Spannung an der Eingangsbuchse kommt an. Für mehr Messungen reichen leider meine Kenntnisse und meine Ausrüstung nicht.....wär eher was für den Dompteur.

17

Mittwoch, 1. Februar 2017, 19:22

Schade dass es der RAM nicht war...

Das kenne ich nur von direkt in die Stromeingangsbuchse integrierten LEDs.
Oder befindet sich beim Lenovo Edge allen Ernstes eine LED auf dem Mainboard, die direkt aus der Eingangsspannung versorgt wird?


Sie ist direkt neben dem Netzteilstecker und wird aus einem 3v oder 5v LDO versorgt. Weiß grad nicht mehr so genau. Also nicht direkt aus der Eingangsspannung.

EDV-Dompteur

Administrator

Beiträge: 469

Wohnort: Hamburg

Beruf: Techniker

  • Nachricht senden

18

Mittwoch, 1. Februar 2017, 22:34

Gut, der LDO wird aber hinter den Eingangs-MOSFETs sitzen.

Wenn so eine LED also leuchtet, dann werden erstens die MOSFETs wohl OK sein (Ausnahmefall wären leicht leakende MOSFETs), zweitens liegt sicherlich kein Kurzschluss vor.
Natürlich könnte dann noch immer einer der Schaltregler defekt sein; ja, auch ein korruptes BIOS kann deren Anschwingen verhindern.

Aber ungeachtet aller LEDs und wie auch immer die beschaltet sind, würde ich in jedem Fall einmal hinter den MOSFETs messen, ob einwandfreie 19V vorhanden sind und im zweiten Schritt hinter den beiden Schaltreglern.
Das sind gut investierte 10 Sekunden.

Denn ich sage ja nur: WENN sich wirklich goa nix rührt, dann ist der Fehler auf jeden Fall im Bereich der Stromversorgung angesiedelt (Kurzschlüsse zähle ich da hinzu, denn dann nix Spannung!).
Wenn sich aber 'n Büschn watt tut, dann kann es noch immer an der Stromversorgung liegen, es kann dann aber auch eine Menge andere Ursachen haben.

Um die Messungen kommt man jedenfalls nicht herum, egal was irgend welche LEDs vermelden.
Macht Technik dir das Leben schwör, ruf' schnell den EDV-Dompteur! ;-)

- Technische Fragen zu Eigenreparaturen bitte nur über das Forum stellen, nicht per E-Mail! -

Zur Zeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher